IT Solution& Services

Join me to provide IT Environment about Microsoft, Network, services, servers, XOS, solution, support for all to reach to the Top
 
HomeHome  CalendarCalendar  FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  RegisterRegister  Log in  
POST Master: Forums under construction and still new, share me by your information idea and try to be with Top management thanks "Mohd Zeitoun"
Search
 
 

Display results as :
 
Rechercher Advanced Search
Keywords
Latest topics

Share | 
 

 Data vlan and voice Vlan configuration with ip telephony

View previous topic View next topic Go down 
AuthorMessage
mohammad zeitoun
Forum Owner
Forum Owner


Posts : 55
Join date : 2015-06-27
Age : 35
Location : lebanon

PostSubject: Data vlan and voice Vlan configuration with ip telephony    Tue Jul 07, 2015 10:18 am

hi to all

please look at the tepology  and see the configuration












 will start - with switch configuration
I- creating Vlans and trunk




Code:

[color=#006600]1: Switch>
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#vlan 10
S1(config-vlan)#name Data
S1(config-vlan)#vlan 20
S1(config-vlan)#name Voice
S1(config-vlan)#vlan 99
S1(config-vlan)#name Management
S1(config-vlan)#exit
S1(config)#int
S1(config)#interface vlan 99
%LINK-5-CHANGED: Interface Vlan99, changed state to up 
S1(config-if)#ip add 192.168.99.10 255.255.255.0
S1(config-if)#no shut
S1(config-if)#exit
S1(config)#ip def
S1(config)#ip default-gateway  192.168.99.1
S1(config)#int
S1(config)#interface  fa0/1
S1(config-if)#sw
S1(config-if)#switchport mode t
S1(config-if)#switchport mode trunk
S1(config-if)#sw
S1(config-if)#switchport t
S1(config-if)#switchport trunk native v
S1(config-if)#switchport trunk native vlan 99
S1(config-if)#no shut
S1(config-if)#no shutdown 
S1(config-if)#exit
S1(config)#
%LINK-5-CHANGED: Interface FastEthernet0/3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up
%LINK-5-CHANGED: Interface FastEthernet0/4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state to up[/color]
[color=#006600]S1(config)#
S1(config)#int
S1(config)#interface ra
S1(config)#interface range  fa0/2-4
S1(config-if-range)#sw
S1(config-if-range)#switchport m
S1(config-if-range)#switchport mode a
S1(config-if-range)#switchport mode access
S1(config-if-range)#sw
S1(config-if-range)#switchport ac
S1(config-if-range)#switchport access v
S1(config-if-range)#switchport access vlan 10
S1(config-if-range)#sw
S1(config-if-range)#switchport v
S1(config-if-range)#switchport voice v
S1(config-if-range)#switchport voice vlan 20 
S1(config-if-range)#no sh
S1(config-if-range)#no shutdown
S1(config-if-range)#exit[/color]





2- creating Sub-interfaces . and dhcp  from router and enabling IP-Telephony  Services





Router>en
Router#conf t
Router#conf terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int
Router(config)#interface  fa0/0
Router(config-if)#no sh
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Router(config)#interface fa0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
Router(config-subif)#ip add 192.168.10.1 255.255.255.0
% Configuring IP routing on a LAN subinterface is only allowed if that
subinterface is already configured as part of an IEEE 802.10, IEEE 802.1Q,
or ISL vLAN.
Router(config-subif)#en
Router(config-subif)#encapsulation d
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip add 192.168.10.1 255.255.255.0
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#in
Router(config)#interface fa0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#en
Router(config-subif)#encapsulation d
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 192.168.20.1 255.255.255.0
Router(config-subif)#no sh
Router(config-subif)#no shutdown
Router(config-subif)#exit
Router(config)#in
Router(config)#interface fa0/0.99
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.99, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.99, changed state to up
Router(config-subif)#en
Router(config-subif)#encapsulation d
Router(config-subif)#encapsulation dot1Q 99 n
Router(config-subif)#encapsulation dot1Q 99 native
Router(config-subif)#ip add 192.168.99.1 255.255.255.0
Router(config-subif)#exit
Router(config)#ip dh
Router(config)#ip dhcp ex
Router(config)#ip dhcp excluded-address  192.168.10.1 192.168.10.9
Router(config)#ip dhcp excluded-address  192.168.20.1 192.168.20.9
Router(config)#ip dh
Router(config)#ip dhcp pool Data
Router(dhcp-config)#net
Router(dhcp-config)#network 192.168.10.0
% Incomplete command.
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#de
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#?
  default-router  Default routers
  dns-server      Set name server
  exit            Exit from DHCP pool configuration mode
  network         Network number and mask
  no              Negate a command or set its defaults
  option          Raw DHCP options
Router(dhcp-config)#
Router(dhcp-config)#
Router(dhcp-config)#
Router(dhcp-config)#ip dhc
Router(dhcp-config)#exit
Router(config)#ip dhc
Router(config)#ip dhcp pool Voice
Router(dhcp-config)#network 192.168.20.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.20.1
Router(dhcp-config)#option ?
  <0-254>  DHCP option code
Router(dhcp-config)#option 150 ip 192.168.20.1
Router(dhcp-config)#exit
Router(config)#te
Router(config)#telephony-service
Router(config-telephony)#max-?
max-dn  max-ephones 
Router(config-telephony)#max-dn 3
Router(config-telephony)#?
  auto             Define dn range for auto assignment
  auto-reg-ephone  Enable Ephone Auto-Registration
  create           create cnf for ethernet phone
  exit             Exit from telephony config mode
  ip               Define IP address and port for Telephony-Service/Fallback
  keepalive        Define keepalive timeout period to unregister IP phones
  max-dn           Maximum directory numbers supported
  max-ephones      Define max number of IP phones
  no               Negate or set default values of a command
Router(config-telephony)#max-e
Router(config-telephony)#max-ephones 3
Router(config-telephony)#ip sou
Router(config-telephony)#ip source-address 192.168.20.1 port ?
  <2000-9999>  Specify the port: 2000 - 9999
Router(config-telephony)#ip source-address 192.168.20.1 port 2000
Router(config-telephony)#exit
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)#
Router(config)#ephone-dn 1
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 1.1, changed state to up

Router(config-ephone-dn)#number 101
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 2
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 2.1, changed state to up

Router(config-ephone-dn)#number 102
Router(config-ephone-dn)#exit
Router(config)#ephone-dn 3
Router(config-ephone-dn)#%LINK-3-UPDOWN: Interface ephone_dsp DN 3.1, changed state to up

Router(config-ephone-dn)#number 103
Router(config-ephone-dn)#exit
Router(config)#ephone 1
Router(config-ephone)#type ?
  7960  Cisco IP Phone 7960
  CIPC  Cisco IP Phone CIPC
  ata   ATA  phone emulation for analog phone
Router(config-ephone)#type 7960
Router(config-ephone)#mac?
mac-address 
Router(config-ephone)#mac ?
  H.H.H  Mac address
Router(config-ephone)#but
Router(config-ephone)#button 1: ?
  <cr>
Router(config-ephone)#button 1:?
LINE 
Router(config-ephone)#button 1:1
Need to configure ephone mac address or VM station-id
Router(config-ephone)#%DHCPD-4-PING_CONFLICT: DHCP address conflict:  server pinged 192.168.20.10.
Router(config-ephone)#mac ?
  H.H.H  Mac address
Router(config-ephone)#but
Router(config-ephone)#button 1: ?
  <cr>
Router(config-ephone)#button 1:?
LINE 
Router(config-ephone)#button 1:1
Need to configure ephone mac address or VM station-id
Router(config-ephone)#%DHCPD-4-PING_CONFLICT: DHCP address conflict:  server pinged 192.168.20.10.
* here better to trun off telephone and turn on to be registered
Router(config-ephone)#bu
Router(config-ephone)#button  1:1
Router(config-ephone)#
%IPPHONE-6-REGISTER: ephone-1 IP:192.168.20.11 Socket:2 DeviceType:Phone has registered.

Router(config-ephone)#exit
Router(config)#eph
Router(config)#ephone 2
Router(config-ephone)#type 7960
Router(config-ephone)#but
Router(config-ephone)#button 1:2
Router(config-ephone)#exit
Router(config)#
%IPPHONE-6-REGISTER: ephone-2 IP:192.168.20.12 Socket:2 DeviceType:Phone has registered.

Router(config)#ephone 3
Router(config-ephone)#but
Router(config-ephone)#button 1:3
Router(config-ephone)#type 7960
%IPPHONE-6-REGISTER: ephone-3 IP:192.168.20.10 Socket:2 DeviceType:Phone has registered.

Router(config-ephone)#type 7960
Router(config-ephone)#exit
Router(config)#show ephones
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#
Router#show ep
Router#show ephone
ephone-1 Mac:0001.C92A.5C76 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.20.11 1087 7960   keepalive 43 max_line 2
 button 1: dn 1  number 101 CH1   IDLE
ephone-2 Mac:000C.CFEA.4BAC TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8 mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.20.12 1095 7960   keepalive 43 max_line 2
 button 1: dn 2  number 102 CH1   IDLE
ephone-3 Mac:00E0.F949.5790 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 12 and Server in ver 8 mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8
IP:192.168.20.10 1100 7960   keepalive 43 max_line 2
 button 1: dn 3  number 103 CH1   IDLE
here : IDLE it is down so he is waiting to call
Router#copy running-config startup-config
ok



that is all
any question just ask
Back to top Go down
View user profile http://it-solution.niceboard.com
 
Data vlan and voice Vlan configuration with ip telephony
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» Orbital Evolution of a Saturn-Jupiter configuration within a disk
» My Sheep Will Hear My Voice...
» Bid Data Sheet
» Bid Data Sheet vs Instruction to Bidders (Infrastructure)
» Bid Data Sheet ITB clause 1.2

Permissions in this forum:You cannot reply to topics in this forum
IT Solution& Services  :: Network Section :: cisco :: Cisco Labs-
Jump to: